HeroEditor4D Reference

HeroEditor4D Reference

Namespaces
 | Name | Description
Namespace | Assets.HeroEditor4D.Common.CharacterScripts |
Namespace | Assets.HeroEditor4D.Common.EditorScripts |
Namespace | Assets.HeroEditor4D.Common.ExampleScripts |
Top

TOPIC-FOOTER


Assets.HeroEditor4D.Common.CharacterScripts Namespace

Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Classes
 | Name | Description
Public class | AnimationEvents | Animation events. If you want to get animation callback, use it. For example, if you want to know exact hit moment for attack animation, use custom event 'Hit' that is fired in most attack animations.
Public class | Character | Character presentation in editor. Contains sprites, renderers, animation and so on.
Public class | Character4D | Controls 4 characters (for each direction).
Public class | CharacterAnimation | Used to play animations.
Public class | LayerManager | Used to order sprite layers (character parts).
Public class | MeleeWeapon | General melee weapon behaviour. First thing you need to check is hit event. Use animation events or check user input. Second thing is to resolve impacts to other objects (enemies, environment). Use collisions or raycasts.
Top
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1


AnimationEvents Class

See Also

Animation events. If you want to get animation callback, use it. For example, if you want to know exact hit moment for attack animation, use custom event 'Hit' that is fired in most attack animations.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class AnimationEvents
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AnimationEvents : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class AnimationEvents : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class AnimationEvents
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | CustomEvent(string) | Called from animation.
Public method | ResetAnimation() | Reset animation.
Public method | SetBool(string) | Set bool param, usage example: Idle=false
Public method | SetExpression(string) | Set characters' expression. Called from animation.
Public method | SetInteger(string) | Set integer param, usage example: WeaponType=2
Top
Events
 | Name | Description
Public event | OnCustomEvent | Subscribe it to get animation callback.
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.CharacterScripts.AnimationEvents
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.CharacterScripts Namespace


AnimationEvents Methods

AnimationEvents Class See Also

The following tables list the members exposed by the AnimationEvents type.

Methods
 | Name | Description
Public method | CustomEvent(string) | Called from animation.
Public method | ResetAnimation() | Reset animation.
Public method | SetBool(string) | Set bool param, usage example: Idle=false
Public method | SetExpression(string) | Set characters' expression. Called from animation.
Public method | SetInteger(string) | Set integer param, usage example: WeaponType=2
Top
See Also
AnimationEvents Class


AnimationEvents.CustomEvent Method

Called from animation.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub CustomEvent( _
   ByVal eventName As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void CustomEvent(
   string eventName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CustomEvent(
   String^ eventName
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CustomEvent(
    eventName : String
);
This language is not supported or no code example is available.

Parameters

eventName

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


AnimationEvents.ResetAnimation Method

Reset animation.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub ResetAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void ResetAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void ResetAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResetAnimation();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


AnimationEvents.SetBool Method

Set bool param, usage example: Idle=false

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetBool( _
   ByVal value As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetBool(
   string value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetBool(
   String^ value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetBool(
    value : String
);
This language is not supported or no code example is available.

Parameters

value

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


AnimationEvents.SetExpression Method

Set characters' expression. Called from animation.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetExpression( _
   ByVal expression As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetExpression(
   string expression
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetExpression(
   String^ expression
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetExpression(
    expression : String
);
This language is not supported or no code example is available.

Parameters

expression

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


AnimationEvents.SetInteger Method

Set integer param, usage example: WeaponType=2

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetInteger( _
   ByVal value As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetInteger(
   string value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetInteger(
   String^ value
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetInteger(
    value : String
);
This language is not supported or no code example is available.

Parameters

value

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


AnimationEvents Events

AnimationEvents Class See Also

The following tables list the members exposed by the AnimationEvents type.

Events
 | Name | Description
Public event | OnCustomEvent | Subscribe it to get animation callback.
Top
See Also
AnimationEvents Class


OnCustomEvent Event

Subscribe it to get animation callback.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Event OnCustomEvent As Action(Of String)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public event Action<string> OnCustomEvent
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
event Action<String^>^ OnCustomEvent {
}
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript supports the use of events, but not the declaration of new ones.
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
AnimationEvents Class


Character Class

Character presentation in editor. Contains sprites, renderers, animation and so on.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Character
    Inherits CharacterBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Character : CharacterBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Character : public CharacterBase^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Character
   extends CharacterBase
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | EquipArmor(List<Sprite>) | Equip armor.
Public method | EquipBoots(List<Sprite>) | Equip boots.
Public method | EquipBow(List<Sprite>) | Equip bow.
Public method | EquipGloves(List<Sprite>) | Equip gloves.
Public method | EquipHelmet(Sprite) | Equip helmet.
Public method | EquipLowerArmor(List<Sprite>) | Equip lower armor.
Public method | EquipMeleeWeapon(Sprite, Sprite, bool) | Equip melee weapon.
Public method | EquipMeleeWeaponPaired(Sprite, Sprite, Sprite, Sprite) | Equip paired melee weapons.
Public method | EquipShield(Sprite) | Equip shield.
Public method | EquipUpperArmor(List<Sprite>) | Equip armor.
Public method | Initialize() | Initializes character renderers with selected sprites.
Public method | LoadFromJson(string) |
Public method | OnEnable() | Called automatically when object was enabled.
Public method | OnValidate() | Called automatically when something was changed.
Public method | ResetEquipment() | Remove all equipment.
Public method | SetBody(Sprite, List<Sprite>) | Set character's body.
Public method | SetExpression(string) | Set character's expression.
Public method | ToJson() |
Public method | UpdateAnimation() | Refer to Animator window to learn animation params, states and transitions!
Top
Fields
 | Name | Description
Public field | LayerManager |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
HeroEditor.Common.CharacterBase
Assets.HeroEditor4D.Common.CharacterScripts.Character
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also


Character Methods

Character Class See Also

The following tables list the members exposed by the Character type.

Methods
 | Name | Description
Public method | EquipArmor(List<Sprite>) | Equip armor.
Public method | EquipBoots(List<Sprite>) | Equip boots.
Public method | EquipBow(List<Sprite>) | Equip bow.
Public method | EquipGloves(List<Sprite>) | Equip gloves.
Public method | EquipHelmet(Sprite) | Equip helmet.
Public method | EquipLowerArmor(List<Sprite>) | Equip lower armor.
Public method | EquipMeleeWeapon(Sprite, Sprite, bool) | Equip melee weapon.
Public method | EquipMeleeWeaponPaired(Sprite, Sprite, Sprite, Sprite) | Equip paired melee weapons.
Public method | EquipShield(Sprite) | Equip shield.
Public method | EquipUpperArmor(List<Sprite>) | Equip armor.
Public method | Initialize() | Initializes character renderers with selected sprites.
Public method | LoadFromJson(string) |
Public method | OnEnable() | Called automatically when object was enabled.
Public method | OnValidate() | Called automatically when something was changed.
Public method | ResetEquipment() | Remove all equipment.
Public method | SetBody(Sprite, List<Sprite>) | Set character's body.
Public method | SetExpression(string) | Set character's expression.
Public method | ToJson() |
Public method | UpdateAnimation() | Refer to Animator window to learn animation params, states and transitions!
Top
See Also
Character Class


Character.EquipArmor Method

Equip armor.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipArmor( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipArmor(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipArmor(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from armor atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Armor[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipBoots Method

Equip boots.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipBoots( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipBoots(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipBoots(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from armor atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Armor[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipBow Method

Equip bow.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipBow( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipBow(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipBow(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from bow atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Bow[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipGloves Method

Equip gloves.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipGloves( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipGloves(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipGloves(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from armor atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Armor[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipHelmet Method

Equip helmet.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipHelmet( _
   ByVal sprite As Sprite _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipHelmet(
   Sprite sprite
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipHelmet(
   Sprite^ sprite
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipHelmet(
    sprite : Sprite
);
This language is not supported or no code example is available.

Parameters

sprite

Type: Sprite

Helmet sprite. It can be obtained from SpriteCollection.Instance.Helmet[].Sprite.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipLowerArmor Method

Equip lower armor.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipLowerArmor( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipLowerArmor(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipLowerArmor(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from armor atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Armor[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipMeleeWeapon Method

Equip melee weapon.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipMeleeWeapon( _
   ByVal sprite As Sprite, _
   ByVal trail As Sprite, _
   Optional ByVal twoHanded As Boolean = false _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipMeleeWeapon(
   Sprite sprite,
   Sprite trail,
   bool twoHanded = false
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipMeleeWeapon(
   Sprite^ sprite,
   Sprite^ trail,
   bool twoHanded
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipMeleeWeapon(
    sprite : Sprite,
    trail : Sprite,
    twoHanded : boolean
);
This language is not supported or no code example is available.

Parameters

sprite

Type: Sprite

Weapon sprite. It can be obtained from SpriteCollection.Instance.MeleeWeapon1H/2H[].Sprites.

trail

Type: Sprite

Melee weapon trail. It is LinkedSprite of SpriteGroupEntry.

twoHanded

Type: bool

If two-handed melee weapon.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipMeleeWeaponPaired Method

Equip paired melee weapons.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipMeleeWeaponPaired( _
   ByVal spritePrimary As Sprite, _
   ByVal trailPrimary As Sprite, _
   ByVal spriteSecondary As Sprite, _
   ByVal trailSecondary As Sprite _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipMeleeWeaponPaired(
   Sprite spritePrimary,
   Sprite trailPrimary,
   Sprite spriteSecondary,
   Sprite trailSecondary
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipMeleeWeaponPaired(
   Sprite^ spritePrimary,
   Sprite^ trailPrimary,
   Sprite^ spriteSecondary,
   Sprite^ trailSecondary
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipMeleeWeaponPaired(
    spritePrimary : Sprite,
    trailPrimary : Sprite,
    spriteSecondary : Sprite,
    trailSecondary : Sprite
);
This language is not supported or no code example is available.

Parameters

spritePrimary

Type: Sprite

trailPrimary

Type: Sprite

spriteSecondary

Type: Sprite

trailSecondary

Type: Sprite

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipShield Method

Equip shield.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipShield( _
   ByVal sprite As Sprite _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipShield(
   Sprite sprite
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipShield(
   Sprite^ sprite
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipShield(
    sprite : Sprite
);
This language is not supported or no code example is available.

Parameters

sprite

Type: Sprite

Shield sprite. It can be obtained from SpriteCollection.Instance.Shield[].Sprite.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.EquipUpperArmor Method

Equip armor.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipUpperArmor( _
   ByVal sprites As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipUpperArmor(
   List<Sprite> sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipUpperArmor(
   List<Sprite^>^ sprites
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

sprites

Type: List<Sprite>

A list of sprites from armor atlas (multiple sprite). It can be obtained from SpriteCollection.Instance.Armor[].Sprites.

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.Initialize Method

Initializes character renderers with selected sprites.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Initialize();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.LoadFromJson Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub LoadFromJson( _
   ByVal serialized As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void LoadFromJson(
   string serialized
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadFromJson(
   String^ serialized
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadFromJson(
    serialized : String
);
This language is not supported or no code example is available.

Parameters

serialized

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.OnEnable Method

Called automatically when object was enabled.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnEnable()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnEnable()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnEnable()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnEnable();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.OnValidate Method

Called automatically when something was changed.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnValidate();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.ResetEquipment Method

Remove all equipment.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub ResetEquipment()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void ResetEquipment()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void ResetEquipment()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ResetEquipment();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.SetBody Method

Set character's body.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetBody( _
   ByVal head As Sprite, _
   ByVal body As List(Of Sprite) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetBody(
   Sprite head,
   List<Sprite> body
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetBody(
   Sprite^ head,
   List<Sprite^>^ body
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

head

Type: Sprite

body

Type: List<Sprite>

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.SetExpression Method

Set character's expression.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetExpression( _
   ByVal expression As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetExpression(
   string expression
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetExpression(
   String^ expression
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetExpression(
    expression : String
);
This language is not supported or no code example is available.

Parameters

expression

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.ToJson Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function ToJson() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override string ToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ToJson() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character.UpdateAnimation Method

Refer to Animator window to learn animation params, states and transitions!

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub UpdateAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void UpdateAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void UpdateAnimation()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function UpdateAnimation();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character Fields

Character Class See Also

The following tables list the members exposed by the Character type.

Fields
 | Name | Description
Public field | LayerManager |
Top
See Also
Character Class


LayerManager Field

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Header("Service")> _
Public LayerManager As LayerManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Header("Service")]
public LayerManager LayerManager
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Header("Service")]
public:
LayerManager^ LayerManager;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Header("Service")
LayerManager : LayerManager
This language is not supported or no code example is available.

Field Value

Type: LayerManager
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character Class


Character4D Class

Controls 4 characters (for each direction).

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class Character4D
    Inherits Character4DBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Character4D : Character4DBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class Character4D : public Character4DBase^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class Character4D
   extends Character4DBase
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | CopyFrom(Character4DBase) |
Public method | Initialize() |
Public method | LoadFromJson(string) |
Public method | OnValidate() |
Public method | ToJson() |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
HeroEditor.Common.Character4DBase
Assets.HeroEditor4D.Common.CharacterScripts.Character4D
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also


Character4D Methods

Character4D Class See Also

The following tables list the members exposed by the Character4D type.

Methods
 | Name | Description
Public method | CopyFrom(Character4DBase) |
Public method | Initialize() |
Public method | LoadFromJson(string) |
Public method | OnValidate() |
Public method | ToJson() |
Top
See Also
Character4D Class


Character4D.CopyFrom Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub CopyFrom( _
   ByVal character As Character4DBase _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void CopyFrom(
   Character4DBase character
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void CopyFrom(
   Character4DBase^ character
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function CopyFrom(
    character : Character4DBase
);
This language is not supported or no code example is available.

Parameters

character

Type: Character4DBase

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character4D Class


Character4D.Initialize Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Initialize()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Initialize();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character4D Class


Character4D.LoadFromJson Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub LoadFromJson( _
   ByVal json As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void LoadFromJson(
   string json
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadFromJson(
   String^ json
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadFromJson(
    json : String
);
This language is not supported or no code example is available.

Parameters

json

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character4D Class


Character4D.OnValidate Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnValidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnValidate();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character4D Class


Character4D.ToJson Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Function ToJson() As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override string ToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ ToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ToJson() : String;
This language is not supported or no code example is available.

Return Value

Type: string
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Character4D Class


CharacterAnimation Class

Used to play animations.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CharacterAnimation
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterAnimation : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CharacterAnimation : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterAnimation
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | Attack() |
Public method | Move() |
Public method | Shot() |
Public method | Slash() |
Public method | Stand() |
Top
Fields
 | Name | Description
Public field | Animator |
Public field | Character |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.CharacterScripts.CharacterAnimation
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also


CharacterAnimation Methods

CharacterAnimation Class See Also

The following tables list the members exposed by the CharacterAnimation type.

Methods
 | Name | Description
Public method | Attack() |
Public method | Move() |
Public method | Shot() |
Public method | Slash() |
Public method | Stand() |
Top
See Also
CharacterAnimation Class


CharacterAnimation.Attack Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Attack()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Attack()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Attack()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Attack();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


CharacterAnimation.Move Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Move()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Move()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Move()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Move();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


CharacterAnimation.Shot Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Shot()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Shot()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Shot()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Shot();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


CharacterAnimation.Slash Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Slash()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Slash()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Slash()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Slash();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


CharacterAnimation.Stand Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Stand()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Stand()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Stand()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Stand();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


CharacterAnimation Fields

CharacterAnimation Class See Also

The following tables list the members exposed by the CharacterAnimation type.

Fields
 | Name | Description
Public field | Animator |
Public field | Character |
Top
See Also
CharacterAnimation Class


Animator Field

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Animator As Animator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Animator Animator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Animator^ Animator;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Animator : Animator
This language is not supported or no code example is available.

Field Value

Type: Animator
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


Character Field

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Character As Character4D
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character4D Character
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Character4D^ Character;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character : Character4D
This language is not supported or no code example is available.

Field Value

Type: Character4D
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterAnimation Class


LayerManager Class

Used to order sprite layers (character parts).

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class LayerManager
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class LayerManager : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class LayerManager : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class LayerManager
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | ReadCurrentOrderBySortingOrder() | Read ordered sprite list by Sorting Order.
Public method | ReadCurrentOrderByZCoortidate() | Read ordered sprite list by Z coortidate.
Public method | SetOrderBySortingOrder() | Set layers order by Sorting Order.
Public method | SetOrderByZCoordinate() | Set layers order by Z coortidate.
Public method | SetSortingGroupOrder(int) |
Top
Fields
 | Name | Description
Public field | SortingGroup | SortingGroup can be used when you have multiple characters on scene.
Public field | SortingOrderOffset | Two different characters must have different offsets (0 and 1000 for example).
Public field | SortingOrderStep | Step between two sprites (layers).
Public field | Sprites | Full list of sprites
Public field | ZStep | Step between two sprites (layers).
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.CharacterScripts.LayerManager
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also


LayerManager Methods

LayerManager Class See Also

The following tables list the members exposed by the LayerManager type.

Methods
 | Name | Description
Public method | ReadCurrentOrderBySortingOrder() | Read ordered sprite list by Sorting Order.
Public method | ReadCurrentOrderByZCoortidate() | Read ordered sprite list by Z coortidate.
Public method | SetOrderBySortingOrder() | Set layers order by Sorting Order.
Public method | SetOrderByZCoordinate() | Set layers order by Z coortidate.
Public method | SetSortingGroupOrder(int) |
Top
See Also
LayerManager Class


LayerManager.ReadCurrentOrderBySortingOrder Method

Read ordered sprite list by Sorting Order.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub ReadCurrentOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void ReadCurrentOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void ReadCurrentOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ReadCurrentOrderBySortingOrder();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


LayerManager.ReadCurrentOrderByZCoortidate Method

Read ordered sprite list by Z coortidate.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub ReadCurrentOrderByZCoortidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void ReadCurrentOrderByZCoortidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void ReadCurrentOrderByZCoortidate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ReadCurrentOrderByZCoortidate();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


LayerManager.SetOrderBySortingOrder Method

Set layers order by Sorting Order.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetOrderBySortingOrder()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetOrderBySortingOrder();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


LayerManager.SetOrderByZCoordinate Method

Set layers order by Z coortidate.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetOrderByZCoordinate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetOrderByZCoordinate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetOrderByZCoordinate()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetOrderByZCoordinate();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


LayerManager.SetSortingGroupOrder Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetSortingGroupOrder( _
   ByVal index As Integer _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetSortingGroupOrder(
   int index
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetSortingGroupOrder(
   int index
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetSortingGroupOrder(
    index : int
);
This language is not supported or no code example is available.

Parameters

index

Type: int

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


LayerManager Fields

LayerManager Class See Also

The following tables list the members exposed by the LayerManager type.

Fields
 | Name | Description
Public field | SortingGroup | SortingGroup can be used when you have multiple characters on scene.
Public field | SortingOrderOffset | Two different characters must have different offsets (0 and 1000 for example).
Public field | SortingOrderStep | Step between two sprites (layers).
Public field | Sprites | Full list of sprites
Public field | ZStep | Step between two sprites (layers).
Top
See Also
LayerManager Class


SortingGroup Field

SortingGroup can be used when you have multiple characters on scene.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public SortingGroup As SortingGroup
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SortingGroup SortingGroup
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
SortingGroup^ SortingGroup;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SortingGroup : SortingGroup
This language is not supported or no code example is available.

Field Value

Type: SortingGroup
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


SortingOrderOffset Field

Two different characters must have different offsets (0 and 1000 for example).

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public SortingOrderOffset As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SortingOrderOffset
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int SortingOrderOffset;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SortingOrderOffset : int
This language is not supported or no code example is available.

Field Value

Type: int
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


SortingOrderStep Field

Step between two sprites (layers).

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public SortingOrderStep As Integer
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public int SortingOrderStep
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
int SortingOrderStep;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public SortingOrderStep : int
This language is not supported or no code example is available.

Field Value

Type: int
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


Sprites Field

Full list of sprites

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sprites As List(Of SpriteRenderer)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public List<SpriteRenderer> Sprites
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
List<SpriteRenderer^>^ Sprites;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Field Value

Type: List<SpriteRenderer>
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


ZStep Field

Step between two sprites (layers).

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public ZStep As Single
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public float ZStep
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
float ZStep;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ZStep : float
This language is not supported or no code example is available.

Field Value

Type: float
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
LayerManager Class


MeleeWeapon Class

General melee weapon behaviour. First thing you need to check is hit event. Use animation events or check user input. Second thing is to resolve impacts to other objects (enemies, environment). Use collisions or raycasts.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class MeleeWeapon
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MeleeWeapon : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class MeleeWeapon : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class MeleeWeapon
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | OnDestroy() |
Public method | Start() | Listen animation events to determine hit moments.
Top
Fields
 | Name | Description
Public field | AnimationEvents |
Public field | Edge |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.CharacterScripts.MeleeWeapon
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also


MeleeWeapon Methods

MeleeWeapon Class See Also

The following tables list the members exposed by the MeleeWeapon type.

Methods
 | Name | Description
Public method | OnDestroy() |
Public method | Start() | Listen animation events to determine hit moments.
Top
See Also
MeleeWeapon Class


MeleeWeapon.OnDestroy Method

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnDestroy();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
MeleeWeapon Class


MeleeWeapon.Start Method

Listen animation events to determine hit moments.

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Start();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
MeleeWeapon Class


MeleeWeapon Fields

MeleeWeapon Class See Also

The following tables list the members exposed by the MeleeWeapon type.

Fields
 | Name | Description
Public field | AnimationEvents |
Public field | Edge |
Top
See Also
MeleeWeapon Class


AnimationEvents Field

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public AnimationEvents As AnimationEvents
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AnimationEvents AnimationEvents
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
AnimationEvents^ AnimationEvents;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public AnimationEvents : AnimationEvents
This language is not supported or no code example is available.

Field Value

Type: AnimationEvents
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
MeleeWeapon Class


Edge Field

Namespace: Assets.HeroEditor4D.Common.CharacterScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Edge As Transform
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Transform Edge
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Transform^ Edge;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Edge : Transform
This language is not supported or no code example is available.

Field Value

Type: Transform
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
MeleeWeapon Class


Assets.HeroEditor4D.Common.EditorScripts Namespace

Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Classes
 | Name | Description
Public class | CharacterEditor | Character editor UI and behaviour.
Public class | EditorColorField |
Public class | NavigateButton |
Top
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1

TOPIC-FOOTER


CharacterEditor Class

Character editor UI and behaviour.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CharacterEditor
    Inherits CharacterEditorBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterEditor : CharacterEditorBase
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CharacterEditor : public CharacterEditorBase^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterEditor
   extends CharacterEditorBase
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | Awake() | Called automatically on app start.
Public method | Load(string) |
Public method | Load() | Load character from prefab.
Public method | LoadFromJson() | Load character from json.
Public method | Reset() | Remove all equipment.
Public method | Save(string) |
Public method | Save() | Save character to prefab.
Public method | SaveToJson() | Save character to json.
Public method | Test() | Test character with demo setup.
Top
Fields
 | Name | Description
Public field | PrefabFolder |
Public field | TestRoomSceneName |
Public field | UseEditorColorField |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
HeroEditor.Common.CharacterEditorBase
Assets.HeroEditor4D.Common.EditorScripts.CharacterEditor
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor Methods

CharacterEditor Class See Also

The following tables list the members exposed by the CharacterEditor type.

Methods
 | Name | Description
Public method | Awake() | Called automatically on app start.
Public method | Load(string) |
Public method | Load() | Load character from prefab.
Public method | LoadFromJson() | Load character from json.
Public method | Reset() | Remove all equipment.
Public method | Save(string) |
Public method | Save() | Save character to prefab.
Public method | SaveToJson() | Save character to json.
Public method | Test() | Test character with demo setup.
Top
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Awake Method

Called automatically on app start.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Awake()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Awake()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Awake()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Awake();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Load Method

CharacterEditor Class See Also

Load character from prefab.

Overload List
Name | Description
Load(string) |
Load() | Load character from prefab.
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Load (String) Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub Load( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void Load(
   string path
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Load(
   String^ path
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Load(
    path : String
);
This language is not supported or no code example is available.

Parameters

path

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Load Method

Load character from prefab.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Load()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Load()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Load()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Load();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.LoadFromJson Method

Load character from json.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub LoadFromJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void LoadFromJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void LoadFromJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function LoadFromJson();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Reset Method

Remove all equipment.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Reset();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Save Method

CharacterEditor Class See Also

Save character to prefab.

Overload List
Name | Description
Save(string) |
Save() | Save character to prefab.
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Save (String) Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Overrides Sub Save( _
   ByVal path As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public override void Save(
   string path
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Save(
   String^ path
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Save(
    path : String
);
This language is not supported or no code example is available.

Parameters

path

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Save Method

Save character to prefab.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Save()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Save()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Save()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Save();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.SaveToJson Method

Save character to json.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SaveToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SaveToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SaveToJson()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SaveToJson();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor.Test Method

Test character with demo setup.

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Test()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Test()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Test()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Test();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


CharacterEditor Fields

CharacterEditor Class See Also

The following tables list the members exposed by the CharacterEditor type.

Fields
 | Name | Description
Public field | PrefabFolder |
Public field | TestRoomSceneName |
Public field | UseEditorColorField |
Top
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


PrefabFolder Field

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public PrefabFolder As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string PrefabFolder
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ PrefabFolder;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public PrefabFolder : String
This language is not supported or no code example is available.

Field Value

Type: string
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


TestRoomSceneName Field

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public TestRoomSceneName As String
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public string TestRoomSceneName
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
String^ TestRoomSceneName;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public TestRoomSceneName : String
This language is not supported or no code example is available.

Field Value

Type: string
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


UseEditorColorField Field

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
<Header("Other")> _
Public UseEditorColorField As Boolean
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Header("Other")]
public bool UseEditorColorField
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
[Header("Other")]
public:
bool UseEditorColorField;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public
   Header("Other")
UseEditorColorField : boolean
This language is not supported or no code example is available.

Field Value

Type: bool
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterEditor Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField Class

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class EditorColorField
    Inherits EditorWindow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EditorColorField : EditorWindow
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class EditorColorField : public EditorWindow^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class EditorColorField
   extends EditorWindow
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | OnDestroy() |
Public method | OnGUI() |
 | Open(Color) |
Public method | Update() |
Top
Fields
Name | Description
Color |
Top
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField Methods

EditorColorField Class See Also

The following tables list the members exposed by the EditorColorField type.

Methods
 | Name | Description
Public method | OnDestroy() |
Public method | OnGUI() |
 | Open(Color) |
Public method | Update() |
Top
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField.OnDestroy Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnDestroy()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnDestroy();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField.OnGUI Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub OnGUI()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void OnGUI()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void OnGUI()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function OnGUI();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField.Open Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub Open( _
   ByVal originalColor As Color _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void Open(
   Color originalColor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void Open(
   Color originalColor
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function Open(
    originalColor : Color
);
This language is not supported or no code example is available.

Parameters

originalColor

Type: Color

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField.Update Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Update();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


EditorColorField Fields

EditorColorField Class See Also

The following tables list the members exposed by the EditorColorField type.

Fields
Name | Description
Color |
Top
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


Color Field

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Color As Color
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Color Color
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static Color Color;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static Color : Color
This language is not supported or no code example is available.

Field Value

Type: Color
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
EditorColorField Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


NavigateButton Class

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class NavigateButton
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class NavigateButton : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class NavigateButton : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class NavigateButton
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | Navigate(string) |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.EditorScripts.NavigateButton
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.EditorScripts Namespace


NavigateButton Methods

NavigateButton Class See Also

The following tables list the members exposed by the NavigateButton type.

Methods
 | Name | Description
Public method | Navigate(string) |
Top
See Also
NavigateButton Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


NavigateButton.Navigate Method

Namespace: Assets.HeroEditor4D.Common.EditorScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Navigate( _
   ByVal url As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Navigate(
   string url
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Navigate(
   String^ url
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Navigate(
    url : String
);
This language is not supported or no code example is available.

Parameters

url

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
NavigateButton Class
Assets.HeroEditor4D.Common.EditorScripts Namespace


Assets.HeroEditor4D.Common.ExampleScripts Namespace

Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Classes
 | Name | Description
Public class | CharacterControls | An example of how to handle input and make actions.
Public class | PlayingAnimations | Playing different animations example. For full list of animation params and states please open Animator window and select Human.controller.
Public class | RuntimeSetup | Changing equipment at runtime examples.
Public class | SortingOrderExample | Handle character overlapping example.
Top
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1

TOPIC-FOOTER


CharacterControls Class

An example of how to handle input and make actions.

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class CharacterControls
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterControls : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class CharacterControls : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class CharacterControls
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | Start() |
Public method | Update() |
Top
Fields
 | Name | Description
Public field | CharacterAnimation |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.ExampleScripts.CharacterControls
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.ExampleScripts Namespace


CharacterControls Methods

CharacterControls Class See Also

The following tables list the members exposed by the CharacterControls type.

Methods
 | Name | Description
Public method | Start() |
Public method | Update() |
Top
See Also
CharacterControls Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


CharacterControls.Start Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Start()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Start();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterControls Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


CharacterControls.Update Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Update()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Update();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterControls Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


CharacterControls Fields

CharacterControls Class See Also

The following tables list the members exposed by the CharacterControls type.

Fields
 | Name | Description
Public field | CharacterAnimation |
Top
See Also
CharacterControls Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


CharacterAnimation Field

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public CharacterAnimation As CharacterAnimation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CharacterAnimation CharacterAnimation
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
CharacterAnimation^ CharacterAnimation;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public CharacterAnimation : CharacterAnimation
This language is not supported or no code example is available.

Field Value

Type: CharacterAnimation
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
CharacterControls Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations Class

Playing different animations example. For full list of animation params and states please open Animator window and select Human.controller.

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class PlayingAnimations
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlayingAnimations : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class PlayingAnimations : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class PlayingAnimations
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | Idle() |
Public method | JabMelee2H() |
Public method | Jump() |
Public method | Ready() |
Public method | Reset() |
Public method | Run() |
Public method | ShootBow() |
Public method | SlashMelee1H() |
Public method | Walk() |
Top
Fields
 | Name | Description
Public field | Character |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.ExampleScripts.PlayingAnimations
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations Methods

PlayingAnimations Class See Also

The following tables list the members exposed by the PlayingAnimations type.

Methods
 | Name | Description
Public method | Idle() |
Public method | JabMelee2H() |
Public method | Jump() |
Public method | Ready() |
Public method | Reset() |
Public method | Run() |
Public method | ShootBow() |
Public method | SlashMelee1H() |
Public method | Walk() |
Top
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Idle Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Idle()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Idle()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Idle()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Idle();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.JabMelee2H Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub JabMelee2H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void JabMelee2H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void JabMelee2H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function JabMelee2H();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Jump Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Jump()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Jump()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Jump()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Jump();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Ready Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Ready()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Ready()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Ready()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Ready();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Reset Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Reset()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Reset();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Run Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Run()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Run()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Run()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Run();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.ShootBow Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Function ShootBow() As IEnumerator
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public IEnumerator ShootBow()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
IEnumerator^ ShootBow()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function ShootBow() : IEnumerator;
This language is not supported or no code example is available.

Return Value

Type: IEnumerator
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.SlashMelee1H Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SlashMelee1H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SlashMelee1H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SlashMelee1H()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SlashMelee1H();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations.Walk Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub Walk()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void Walk()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void Walk()
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function Walk();
This language is not supported or no code example is available.
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


PlayingAnimations Fields

PlayingAnimations Class See Also

The following tables list the members exposed by the PlayingAnimations type.

Fields
 | Name | Description
Public field | Character |
Top
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


Character Field

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Character As Character
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character Character
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Character^ Character;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character : Character
This language is not supported or no code example is available.

Field Value

Type: Character
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
PlayingAnimations Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup Class

Changing equipment at runtime examples.

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class RuntimeSetup
    Inherits MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RuntimeSetup : MonoBehaviour
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class RuntimeSetup : public MonoBehaviour^
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class RuntimeSetup
   extends MonoBehaviour
This language is not supported or no code example is available.
Methods
 | Name | Description
Public method | EquipArmor(string, string) |
Public method | EquipBow(string, string) |
Public method | EquipHelmet(string, string) |
Public method | EquipMeleeWeapon1H(string, string) |
Public method | EquipMeleeWeapon2H(string, string) |
Public method | EquipShield(string, string) |
Public method | SetBody(string, string, string, string) | Example call: SetBody("HeadScar", "Basic", "Human", "Basic");
Top
Fields
 | Name | Description
Public field | Character |
Top
Inheritance Hierarchy
System.Object
UnityEngine.Object
UnityEngine.Component
UnityEngine.Behaviour
UnityEngine.MonoBehaviour
Assets.HeroEditor4D.Common.ExampleScripts.RuntimeSetup
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup Methods

RuntimeSetup Class See Also

The following tables list the members exposed by the RuntimeSetup type.

Methods
 | Name | Description
Public method | EquipArmor(string, string) |
Public method | EquipBow(string, string) |
Public method | EquipHelmet(string, string) |
Public method | EquipMeleeWeapon1H(string, string) |
Public method | EquipMeleeWeapon2H(string, string) |
Public method | EquipShield(string, string) |
Public method | SetBody(string, string, string, string) | Example call: SetBody("HeadScar", "Basic", "Human", "Basic");
Top
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipArmor Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipArmor( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipArmor(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipArmor(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipArmor(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipBow Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipBow( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipBow(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipBow(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipBow(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipHelmet Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipHelmet( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipHelmet(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipHelmet(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipHelmet(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipMeleeWeapon1H Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipMeleeWeapon1H( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipMeleeWeapon1H(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipMeleeWeapon1H(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipMeleeWeapon1H(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipMeleeWeapon2H Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipMeleeWeapon2H( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipMeleeWeapon2H(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipMeleeWeapon2H(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipMeleeWeapon2H(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.EquipShield Method

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub EquipShield( _
   ByVal sname As String, _
   ByVal collection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void EquipShield(
   string sname,
   string collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void EquipShield(
   String^ sname,
   String^ collection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function EquipShield(
    sname : String,
    collection : String
);
This language is not supported or no code example is available.

Parameters

sname

Type: string

collection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup.SetBody Method

Example call: SetBody("HeadScar", "Basic", "Human", "Basic");

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetBody( _
   ByVal headName As String, _
   ByVal headCollection As String, _
   ByVal bodyName As String, _
   ByVal bodyCollection As String _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetBody(
   string headName,
   string headCollection,
   string bodyName,
   string bodyCollection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetBody(
   String^ headName,
   String^ headCollection,
   String^ bodyName,
   String^ bodyCollection
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public function SetBody(
    headName : String,
    headCollection : String,
    bodyName : String,
    bodyCollection : String
);
This language is not supported or no code example is available.

Parameters

headName

Type: string

headCollection

Type: string

bodyName

Type: string

bodyCollection

Type: string

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


RuntimeSetup Fields

RuntimeSetup Class See Also

The following tables list the members exposed by the RuntimeSetup type.

Fields
 | Name | Description
Public field | Character |
Top
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


Character Field

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Character As Character
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character Character
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
Character^ Character;
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public Character : Character
This language is not supported or no code example is available.

Field Value

Type: Character
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
RuntimeSetup Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


SortingOrderExample Class

Handle character overlapping example.

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Class SortingOrderExample
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SortingOrderExample
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public ref class SortingOrderExample
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public class SortingOrderExample
This language is not supported or no code example is available.
Methods
 | Name | Description
 | OrderByIndex(Character, Character) | Order characters by sorting order. // TODO: Legacy. Use SortingGroup!
 | OrderByZ(Character, Character) | Order characters by Z coordinate. // TODO: Legacy. Use SortingGroup!
Public method | SetupSortingOrderByY(List<Character>) | Use it when you have a static scene with multiple characters and you want to sort them by Y.
Top
Inheritance Hierarchy
System.Object
Assets.HeroEditor4D.Common.ExampleScripts.SortingOrderExample
Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
Assets.HeroEditor4D.Common.ExampleScripts Namespace


SortingOrderExample Methods

SortingOrderExample Class See Also

The following tables list the members exposed by the SortingOrderExample type.

Methods
 | Name | Description
 | OrderByIndex(Character, Character) | Order characters by sorting order. // TODO: Legacy. Use SortingGroup!
 | OrderByZ(Character, Character) | Order characters by Z coordinate. // TODO: Legacy. Use SortingGroup!
Public method | SetupSortingOrderByY(List<Character>) | Use it when you have a static scene with multiple characters and you want to sort them by Y.
Top
See Also
SortingOrderExample Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


SortingOrderExample.OrderByIndex Method

Order characters by sorting order. // TODO: Legacy. Use SortingGroup!

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OrderByIndex( _
   ByVal front As Character, _
   ByVal back As Character _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OrderByIndex(
   Character front,
   Character back
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OrderByIndex(
   Character^ front,
   Character^ back
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OrderByIndex(
    front : Character,
    back : Character
);
This language is not supported or no code example is available.

Parameters

front

Type: Character

back

Type: Character

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
SortingOrderExample Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


SortingOrderExample.OrderByZ Method

Order characters by Z coordinate. // TODO: Legacy. Use SortingGroup!

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Shared Sub OrderByZ( _
   ByVal front As Character, _
   ByVal back As Character _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static void OrderByZ(
   Character front,
   Character back
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
static void OrderByZ(
   Character^ front,
   Character^ back
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public static function OrderByZ(
    front : Character,
    back : Character
);
This language is not supported or no code example is available.

Parameters

front

Type: Character

back

Type: Character

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
SortingOrderExample Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace


SortingOrderExample.SetupSortingOrderByY Method

Use it when you have a static scene with multiple characters and you want to sort them by Y.

Namespace: Assets.HeroEditor4D.Common.ExampleScripts
Assembly: Assembly-CSharp (in Assembly-CSharp.dll)

Syntax
VB
C#
F#
C++
JScript
Copy
Public Sub SetupSortingOrderByY( _
   ByVal character As List(Of Character) _
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public void SetupSortingOrderByY(
   List<Character> character
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
public:
void SetupSortingOrderByY(
   List<Character^>^ character
)
This language is not supported or no code example is available.
VB
C#
F#
C++
JScript
Copy
JScript does not support generic types and methods.
This language is not supported or no code example is available.

Parameters

character

Type: List<Character>

Applies to

.NET Framework

Supported in: 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1
See Also
SortingOrderExample Class
Assets.HeroEditor4D.Common.ExampleScripts Namespace